Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

At first, I had a simple text object:
Screenshot showing my text object 'Text'

Then I pressed Alt+C and selected Mesh from Curve/Meta/Surf/Text in order to convert the text object into a mesh.

Now I want to apply the Remesh modifier, however, it hides my text in normal mode and in the rendered image (it is visible in the edit mode though!).

Screenshot (normal mode): Normal mode after having selected the Remesh modifier

Screenshot (edit mode): Edit mode after having selected the Remesh modifier

Why is my object invisible in the normal mode and when I render it?

share|improve this question
add comment

2 Answers 2

up vote 5 down vote accepted

The Remesh modifier doesn't seem to work on flat objects so you need to give your text some volume/thickness.

In edit mode select all the faces and press E and extrude the text a little to give it some volume.

The Remesh modifier will now work but will remove all but one letter of the text until 'Remove Disconnected Pieces' is unchecked on the Remesh modifier.

share|improve this answer
    
Thanks a lot! Apart from your solution, setting the "Extrude" value to 0.001 on the F (Text) tab before converting to a mesh also works. –  ComFreek Apr 25 at 16:01
add comment

The remesh modifier tries to divide the volume of an object into a bunch of cubes and create new vertices where the edges of the cubes cross the original mesh. This only works if the mesh has a volume. Thus you need to either extrude the mesh or increase the "Extrude" value of the text before you convert it into a mesh.

enter image description here

You should also disable "Remove Disconnected Pieces" in the modifier and increase the "Octree Depth" value. This value defines how small the cubes used for the remeshing will be. But be careful, don't set it too high. The number of cubes increase with two to the power of octree depth times three. A value of 6 should be enough.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.