Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

This question already has an answer here:

The smooth shading mode is nice, but often times it seems to leave ugly marks where edges are. it doesn't do that between every face, but it does for some faces. I tried flipping normals but all that does is make it lighter or darker, but doesn't actually smooth it out. I tried making all the faces merged, but that didn't help.

enter image description here

share|improve this question

marked as duplicate by iKlsR Apr 4 at 2:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Have you tried recalculating the normals? (Tab > Edit mode > A > Select all > Ctrl+N > recalculate normals) –  gandalf3 Apr 4 at 0:57
    
it literally does nothing to the appearence –  ZCoder Apr 4 at 1:00
    
Related: blender.stackexchange.com/a/6426/599 –  gandalf3 Apr 4 at 1:30
    
that only addresses whether the outer edges are rounded or not. on the model I was referring to the texturing on the side –  ZCoder Apr 4 at 1:35
    
I know, but it's affected by the subserf modifier which I suspect you have on your mesh. If add supporting geometry it will also help with the shading. –  gandalf3 Apr 4 at 1:36
show 2 more comments

2 Answers 2

up vote 2 down vote accepted

You need to add an edge split modifier to make the mesh look right.

Method 1 - modifier

  1. Select Mesh

  2. Add Edge Split modifier

Method 2 - specify shading

Another method you can use it a bit more manual and not a one click solution but it will work just as well in this case.

  1. Select the mesh and go into edit mode.

  2. Select the top polygons that make up the flat surface

  3. Set their shading to flat in the tool panel on the left (t)

enter image description here

share|improve this answer
    
you can also do this by adding edge loops this will help a bit –  Vader Apr 4 at 1:25
add comment

The reason this is shaded oddly is because you have connected faces with very different normals. The reason it looks "wavy" is because (I suspect) you have a subserf modifier on the mesh.

You have two options to fix this while keeping smooth shading on all faces:

  • Disconnect the faces (edge split).

  • Add more faces in between to make the normals more consistent (supporting geometry).

From left to right: Normal cylinder, subsurfed cylinder, subserfed cylinder with supporting geometry.

enter image description here

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.