Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

I tried isolating the two objects via layers, but that removes the shadows as well:

enter image description here

When I don't isolate, I get these little single-pixel reflections on the image material for the background object:

enter image description here

See them? They're annoying. Is there any way to remove them without removing the shadows?

Blend file

share|improve this question
    
Those single pixel reflections are commonly known as Fireflies. You might want to try removing them by enabling No caustics in Render settings > Light Paths, or by using the clamp options. –  gandalf3 Apr 1 at 2:14
    
@gandalf3 - Submit an answer and I'll accept it. That worked great. –  PitaJ Apr 1 at 2:17

1 Answer 1

up vote 3 down vote accepted

Those single pixel reflections are commonly known as fireflies.

Fireflies can often be removed by disabling caustics, as they are usually a result of an unlikely indirect sample of a lamp.

If you don't want or need caustics, then simply enable No Caustics in Render settings > Light paths.

Clamping

If you want to keep caustics, you might try using the Clamp options in Render settings > Sampling. The clamp options will ensure a sample does not return a higher value than the clamp value, but be aware that this can potentially affect highlights and other intentionally bright areas of the render.

To help avoid this, in 2.70 you can now clamp indirect samples (where fireflies are usually found) separately from direct samples.


Also see:

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.