Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

So I have the display measurements addon enabled (I think- I was tremendously ill around the time it happened so I don't quite remember but afaik blender doesn't have native support for edge length displays so I presume that's what happened)(Edit: Apparently it does, thank you Gandalf3) and while trying to texture a mesh I came across this problem:

enter image description here

This happens regardless of what I set the measurement standard to be: the x and y edges of this mesh are always 1/20th of the equivalent z length. Why is this happening? The UV unwrapper interprets the problem in real space but I have imported the exported mesh into Unity with no sudden drastic alterations in size.

It's difficult for me to draw up a texture for the UV when this is happening so I'd rather like to know what's going on.

share|improve this question
    
Blender does have support for edge length displays (along with face area etc.) in 3D view > Properties (N) > Mesh display. Note that you must be in edit mode. –  gandalf3 Mar 29 at 19:06

2 Answers 2

up vote 3 down vote accepted

Measurement scales are always the same, the units used for display are chosen based on the the length being displayed, eg. you will see 10mm not 0.01m.

The problem you show is from an object that was scaled in object mode. This question can give some more insight into other issues with object scales.

When you have a mesh object and an edge in that mesh is 1 metre long directly along the x axis, the object scale is then applied to the mesh which means it might be visually measured at 0.2 metre in length.

Below you can see a default cube that has been scaled on the y axis in object mode and then scaled again in edit mode. Each edge is the same length as you would expect from a cube, the object scale is then applied to give a very rectangular appearance to the drawn cube.

enter image description here

The solution is to apply the scale to the object while in object mode - CtrlA and select Scale.

enter image description here

share|improve this answer
    
Note, you don't have to apply the scale - (there are reasons you may want to keep the object scaled), added own answer. –  ideasman42 Mar 29 at 22:25

In the Editmode Transform panel (right hand region). Enable the global option. Then all measurements will be displayed with object transformation applied.

use global coordinates

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.