Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

Trying to create a face Make Edge/Face F doesn't create the face completely.

enter image description here

Why remains this triangle unfilled?

.blend file

enter image description here

share|improve this question
add comment

3 Answers 3

up vote 5 down vote accepted

There are a lot of double vertices around the face, which meant that the selected edges around the missing triangle were not actually connected to the rest of the selection.

To fix this, select the vertices around that area, or select all (A) and press WR to remove doubles.

You seem to have a lot of doubles, it removed 305 vertices for me. Perhaps an accidentally applied edge split modifier or edge split operator (CtrlE>Edge Split or D)? It's possible to split edges without.

Identifying doubles:

You can tell that the upper left edge is not connected to the selected vertex because the orange gradient that normally appears along selected edges is not visible.

enter image description here

After merging the double vertices with Remove doubles it looks like this:

enter image description here

Now fill will work as expected:

enter image description here

share|improve this answer
    
This is really good I think because this person seems to be just starting out, it's what's needed for this person at his or her skill level. –  MarcClintDion Mar 28 at 11:46
add comment

Common Cause of Mesh Editing Problems

I have found one of the most difficult to detect causes of odd mesh behavior is when vertices, edges or faces exist in the same spot (overlap/are duplicates). This can cause your mesh to be non-manifold and can also cause odd problems like the one you've encountered.

Automatically merge vertices moved to the same location

One easy way to avoid creating duplicate vertices is this: while in Edit mode, enable "Automatically merge vertices moved to the same location":

enter image description here

If you have this enabled when modeling, you most likely won't have to use Remove Doubles later on. NOTE: Enabling this will only merge vertices from that time on while modeling -- it will NOT merge already existing overlapping vertices. To merge already existing ones, use Remove Doubles by doing either of these while in Edit mode:

  • Tools panel -> Tools tab -> Remove section -> Remove Doubles
  • W -> Remove Doubles

Overlapping Edges

However, enabling Automatically Merge Vertices and Remove Doubles won't help you in the case of overlapping edges that have different start and end vertices. I've found 2 common causes of these kinds of overlapping edges: Extruding and Make Edge/Face.

Extruding
Here is a video showing how extruding during editing can cause overlapping edges:

enter image description here

Here, the two edges get overlapped by the one long extruded edge. Notice how even though Automatically Merge Vertices is enabled, the middle vertex (the one moved around at the end of the video) does not get merged because when the edge is extruded, it doesn't have a vertex right there to merge with. The same situation can occur when extruding vertices or faces.

To avoid this problem, don't extrude past/over a vertex (as show above) -- extrude TO each vertex, as shown here:

enter image description here

Since Automatically Merge Vertices is enabled and all edges have they same start and end vertices, they get automatically merged and you don't have problematic overlapping edges or duplicate vertices.

Make Edge/Face
If you use F to make and edge or a face that overlaps a vertex, you'll get overlapping edges, as shown here:

enter image description here

How To Find Existing Overlapping Edges

One easy way to find overlapping edges is this: while in Edit mode use CTRLSHIFTALTM to select & highlight all non-manifold geometry. Now examine those areas and if you see a place where it looks like it should be manifold, but it's highlighted, check there for overlapping edges, duplicate vertices, etc.

One way to find them is to select a vertex and see if it's highlighting indicates it is properly connected to all the appropriate edges. Here's an example of a selected vertex who's highlighting indicates it's not properly connected:

enter image description here

See how it's highlighting doesn't include the horizontal edges? That means it's not connected to them.

Here is a vertex that is properly connected:

enter image description here

It's highlighting includes all four of the surrounding edges, so you know it's properly connected to them.

How To Fix Existing Overlapping Edges

Once you find the offending vertex, grab & drag it to see if a hidden overlapping edge is revealed, as shown in the videos above. Once found, delete the overlapping edge, then put the dragged vertex back into place.

One trick I discovered about how to put the vertex back into place easily is when you are first dragging it out of place, only drag it on one axis, rather than freely in 3, because then you only have to snap it back into place on one axis, rather than 3.

share|improve this answer
    
Great answer. I like the general approach to this. X > Limited Dissolve is another good function for cleaning up floating or excess geometry. –  iKlsR Mar 28 at 20:57
    
Thanks, it was a huge leap forward for me when I discovered all these things that were making my meshes non-manifold, etc. –  Thom Blair III Mar 28 at 21:00
    
What I really wish is Blender would have a "Automatically merge all geometries moved to the same location" or some such feature like Remove Doubles called "Merge Geometries" that would merge overlapping edges & create the necessary vertices, remove doubles, etc. That would be SO great & would speed up the whole modeling process/model clean-up process. –  Thom Blair III Mar 28 at 21:04
add comment

This is because the mesh isn't continuous at a particular spot, (maybe you did an accidental rip V) or there is excess geometry floating somewhere. Run a W > Remove doubles operation and it should work after.

Other things you could try are to look at your mesh in wireframe view to see if you can spot any odd bits, make sure there aren't any inside faces etc and or box select the problem region and perform a X > Limited Dissolve operation.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.