Sign up ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

I want to enable GPU rendering, but there is no option in User Preferences > System:

enter image description here

Why is this? How can I get cycles to render using my GPU?

share|improve this question
I'm using OpenSUSE 13.1 x64 with Nvidia official repo drivers installed. However, despite I bought an nvidia Geforce 650GT, stil have no GPU option available on Blender. What am I missing or doing wrong? –  user3305984 May 15 '14 at 13:42
@user3305984 Without more info it's hard to say. This site isn't really designed for back and forth discussions (as will undoubtedly be the result of troubleshooting etc.), so you'll probably have better luck on a forum like BlenderArtists –  gandalf3 May 29 '14 at 19:19
for Linux mint (an maybe other distros) read this also: –  cegaton May 19 at 17:33

2 Answers 2

up vote 57 down vote accepted

Ensure GPU Support

Currently cycles supports CUDA (Nvidia) devices and has experimental support for OpenCL devices as of 2.75 (added in B7f447). If you are using an AMD/ATI graphics card, see the OpenCL section below. If you are running an older NVIDIA card, ie the Geforce series, support is extremely limited and these are not officially supported, see How to enable GPU rendering on older Nvidia GPUs?


Cycles only supports CUDA GPUs with a CUDA compute ability of 2.0 or higher. To use CUDA, check to make sure your GPU is on this list of CUDA capable GPUs and has a ranking of at least 2.0.

Install Latest Drivers

If your GPU has a CUDA compute ability greater than or equal to 2.0 and you still don't have the option to enable GPU rendering, you can check a couple more things:

Below are instructions for various operating systems. If you are still having issues after trying all the steps listed in this post, try asking for support on BlenderArtists.
This site is not well suited to localized troubleshooting discussions often needed to untangle unusual hardware/driver issues.


Run as root
Due to an issue with some versions of the nvidia drivers, you must run blender (or any other program which uses cuda) as root before you can use any cuda features as a normal user. See this thread for more detail.

Ubuntu-based Distributions

  • Open your driver manager and select the recommended driver and Apply Changes.

    enter image description here

  • You can also use the terminal to install the latest stable driver.

    sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
    sudo apt-get update
    sudo apt-get install nvidia-current

For linux Mint, Ubuntu and Debian variants (and maybe other distributions) you will need to install the package nvidia-modprobe which will detect your nvidia CUDA device and make it available for blender. Read this answer for further instructions


Please note that this is for Debian Jessie (8), the current stable. For instructions for wheezy, please see

First, become super user by typing in su and entering in you password when it asks for it, or by preceding all commands with sudo (will still ask for password the first time), assuming you set it up.

Then type in:

nano /etc/apt/sources.list

And add the line deb jessie main contrib non-free if it's not already there.

Then do an apt-get update, to refresh the package lists on the computer, then finally, install the drivers with:

apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-kernel-dkms

To finish up the actual driver installation, create an Xorg configuration file with the following commands:

mkdir /etc/X11/xorg.conf.d
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf

Than reboot your computer to blacklist (disable) the open source nouvou driver which is loaded by default.

All that is required afterwards, is to install cuda with the following command:

apt-get install nvidia-cuda-toolkit

For more in depth information, please see (only covers the drivers, not cuda). If you are running a GTX 970 or 980 you will need a special build of cuda available here.

Arch Linux

Identifying your GPU:

From the Arch wiki:

If you don't know what GPU you have, you can find out by running:

lspci -k | grep -A 2 -i "VGA"

Drivers and CUDA:

For Arch Linux, installing proprietary Nvidia drivers for your GPU can be as simple as installing the nvidia package and then rebooting:

# pacman -S nvidia
# systemctl reboot

If you are compiling Blender from source, you will also need the CUDA toolkit. You can get it by installing the cuda package:

# pacman -S cuda

Windows 7

  1. Find out what GPU you have in the Device Manager. Go to Start -> Control Panel -> System and Security -> System -> Device Manager), then open the Display adapters tree.

    Screenshot of Device Manager showing an NVIDIA GeForce GTX 580

  2. To find out the architecture of your Windows installation, open a command prompt (search for cmd in the start menu) and run wmic os get osarchitecture.

    enter image description here

    Alternatively, you can get this information from a GUI by going to Start -> Control Panel -> System and Security -> System or by using the keyboard shortcut Windows KeyPause.

    Screenshot showing the architecture of Windows.

  3. Go to the Nvidia Website and select your driver.

    enter image description here

  4. Finally, download and install the proper driver for your architecture. I am assuming you know how to use installers.

    enter image description here

Nvidia Optimus:
If you're running Blender on a notebook with Nvidia Optimus, make sure it uses the dedicated GPU. Either configure Blender to always use the dedicated over the integrated GPU in the Nvidia Control Panel, or right-click Blender.exe (or a shortcut to Blender) and select the Nvidia GPU in the the Run with graphics processor menu:

Run with high-performance Nvidia processor (GPU)


Install the latest Nvidia Driver for you graphics card. You can download them from the Nvidia website.

  1. Open the CUDADriver.pkg file by double clicking it.

    enter image description here

  2. Go through the installer.

    enter image description here

  3. If it installed correctly, there should be a new CUDA option in the System Preferences (the only time you need to go here is to install updates):

    enter image description here

Finally after you have installed your drivers:

  1. Restart your computer

  2. Start Blender.

  3. There should now be an option in the Blender's settings allowing you to select CUDA and your GPU:

    enter image description here

  4. Then select the GPU in Render settings > Render > Device:

    enter image description here


As of blender 2.75, AMD HD 7xxx+ GPUs are officially supported. Other OpenCL devices may work, and can be tested by force-enabling OpenCL with an environment variable:


Also see Is it possible to do OpenCL rendering on Intel processors?


Nvidia OpenCL
To get OpenCL working for nvidia GPUs, ensure that the opencl-nvidia package is installed:

# pacman -S opencl-nvidia

Then run blender with the environment variable set to 1:


In the User Preferences > System there should now be an OpenCL option:

enter image description here

If it's selected, rendering on the GPU will now use opencl. Note that the first time you try to render, blender will have to first compile the necessary kernels which may some time.

share|improve this answer
This was on IRC yesterday: kaito: look how 'gandalf' is replying things… [11:15am] Severin: that's what I call an answer –  MarcClintDion Aug 25 '14 at 10:49
@MarcClintDion This was a team answer, credit must also go to Vader, CharlesL, CoDEmanX, and catlover2 :) –  gandalf3 Aug 25 '14 at 17:55
maybe putting credits at the beginning of a collaboration would help clear things like that up before they happen. It works well to do this with source code. Seems like a good idea for documentation as well. –  MarcClintDion Aug 25 '14 at 19:42
You are my hero. I needed CUDA support on my Mac for more than just Blender. I've been using OpenCL for modeling wave particle physics and I was under the impression that I just needed to wait for the next release of OS X to get proper CUDA drivers. –  lukecampbell Aug 26 '14 at 1:07
@MarcClintDion You can always check this in the revision history. –  iKlsR Sep 21 '14 at 9:29

Also note that you need to change 2 settings to enable GPU rendering. The obvious one is in the User Preferences, System. You also need to set it for the blender file (scene) by clicking on the camera icon (on the left) in the Properties window and under the Render section is a setting for Device.

share|improve this answer

protected by CharlesL Jun 5 '14 at 19:51

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.