Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

I have an object on which I want to apply a bevel modifier. After applying, no matter how high I increase the Width, the bevel stays the same.

About the object:

  1. I've imported a .svg and then converted it to 'Mesh from Curve'
  2. In Edit Mode: Select all Faces → Mesh → Faces → Beautify Fill
  3. Select all Faces → Mesh → Delete → Limited Dissolve
  4. Then I extruded the Object and now I want to create a bevel

You can get the .blend file here.

What I want to achieve is this:

enter image description here

Anyone an Idea?

share|improve this question

3 Answers 3

up vote 6 down vote accepted

You can also directly apply a depth and extrude parameter to the Curve object. This keeps the curve object editable. And it gives cleaner result:

Curve Datablock Editor

Result

share|improve this answer

The 'Clamp Overlap' option is enabled on the modifier. Un-check this to have a bigger bevel.

I would then suggest immediately setting the bevel back to 0 as the current value will be very large.

Use Shift while dragging on the bevel width value to increase the value slowly.

share|improve this answer
    
Yes, that did it, but I the bevels are now really crazy. mediafire.com/?odjqx9m52bb2f9f I think the bevel modifier is a bit confused by the many vertices. You have an idea how to fix this? –  Codey Mar 1 at 16:34
    
You can try turning on the 'angle limit' option and this may help, but this may just be a limit of the modifier when trying to do a bevel that large. –  Ray Mairlot Mar 1 at 16:47
    
@BlenderShark The Clamp overlap option makes sure bevels don't extrude through each other (as in your screenshot). Try leaving it enabled and selecting specific edges to be beveled (with bevel weight or vertex groups). –  gandalf3 Mar 1 at 20:16

The best result I could come up with was from using two bevel modifiers, with vertex groups to limit them to the outer or inner edges. Along with some small geometry changes this prevents the bevel being applied to edges spanning the flat surfaces or sides that was causing artifacts.

enter image description here

I also shaded smooth and added an edge split modifier. The modified file is available here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.