Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've set up the physics of a swinging wrecking ball and set the animation to run for 240 frames. This was not long enough for the entire "swing" of the ball-and-chain.

I'm unable to reset the timeline, but I can set the end frame to (say) 1000 frames, but when I try to play the animation, the animation progress halts at frame 240 and I cannot get it to go any further.

There are no markers or keyframes in the timeline.

What should I do to "force reset" the animation-timeline, to allow changes to the length?

share|improve this question
    
This happened to me, I copied the whole document and paste in a new one, and suddenly it worked again :/ – oreja May 2 at 16:30

The problem you are having is not with timeline, but with the length of the rigid body cache.

The physics systems have cache length settings independent of the scene frame range, so you must ensure that they are set accordingly as well as setting the frame range.

To do this for rigid bodies, set the End frame of the cache in Properties > Scene > Rigid Body Cache to the last frame you want the rigid bodies to be animated:

enter image description here

If you Baked the simulation (rather than just playing the scene animation to make a temporary cache of the simulation), press Free Bake in Properties > Scene > Rigid Body Cache to remove and "unlock" that cache:

enter image description here

share|improve this answer
    
Just to highlight the second paragraph - This applies to all simulations, smoke, cloth, soft body and dynamic paint all have similar cache setups within their settings. Rigid body differs in that the cache is located within the scene settings not under physics properties, while fluid only allows you to set the folder for the cache. – sambler Feb 5 '14 at 4:59
    
@sambler Particles also have this. – gandalf3 Feb 5 '14 at 8:27

Once the Rigid Body World is created in the scene, by default, the Rigid Body Cache frame range uses the current frame range. You need to manually change it in the Scene -> Rigid Body Cache.

enter image description here

share|improve this answer

there seemes to be a bug in vers 2.62 with the particleSimulation cache. if your timeline range for instance is 200fr and your particle cash range is also 200, but the cash is still only calculated till frame 100, you have to change the "frame range" in the properties panel at the render dimensions panel.

share|improve this answer
    
For me the timeline frame range and the properties panel frame range are one and the same; changing one changes the other. This goes for modern blender (2.76b atm) as well as 2.62 – gandalf3 Feb 11 at 11:32

protected by cegaton May 2 at 16:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.