Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

I have a hair texture , and i took away the white background , but the white hasn't gone away yet!? I want it so all the white is gone and it only shows the colours on the texture .

Clearly transparent texture showing white

![Added][3]

enter image description here

share|improve this question
    
possible duplicate of How can I setup a Material in Cycles for Z-Transparency? –  gandalf3 Feb 2 at 4:33
add comment

1 Answer 1

up vote 4 down vote accepted

There are generally four steps to make sure the viewport alpha display:

  • Set Transparency Alpha value to 0.000 in Material setting;
  • Toggle Alpha influence in Texture setting;
  • Switch to GLSL shading mode in 3D View Property panel;
  • Use Texture as viewport shading type.

enter image description here

Besides, make sure Using Alpha is toggled in Texture panel, although it's set as default. And you may want to use UV as the coordinate type of texture mapping for most of the case.


However, it is interesting that you can even preview it without assigning any material, even in the default Multitexture shading mode (just like when you drag and drop an local image onto a object in the scene). And of course, it cannot be rendered, since no material assigned.

enter image description here

share|improve this answer
    
Wow!!! you have got my attention , it DOES work , but in the render image some of it turns out like this?? ( i added a new picture ) –  Knuckles209cp Feb 2 at 4:30
    
I really wonder your settings for materal and texture. Would you also paste the screenshot for that? or we can go to the chatroom now :) (I'm in the one called Renderfarm). –  Leon Cheung Feb 2 at 4:33
    
ill post a picture now :) –  Knuckles209cp Feb 2 at 4:45
    
You don't need to toggle off the color influence, in this case. So, toggle both Color and Alpha, as shown in my picture. –  Leon Cheung Feb 2 at 4:50
    
Ok i have it working now :) Thank you very much –  Knuckles209cp Feb 2 at 4:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.