Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

I often find that I can zoom in to a point, but then cannot zoom any more, even when there is a lot of room to zoom to the meshes on the scene.

This is particularly annoying in the following scenario:

I often land up left clicking on the scene and the 3D cursor shifts there. I use Shift+C to shift the 3D cursor back to the origin. However, this also centers the view on the cursor and shifts the view to show all objects, and sometimes this zooms things way out – at this point, if I try to zoom in, I can zoom in to a point (using the pinch/zoom on trackpad), but then it stops zooming in.

How do I zoom in after that? Is there anything else I am doing wrong in this case?

share|improve this question
    
Thanks, all - that was extremely informative! Very very useful and enhanced my understanding a lot! –  Anand Jun 8 '13 at 1:53
1  
By the way, you can use Shift-S to snap the cursor without moving the view. –  WChargin Jun 10 '13 at 1:41

5 Answers 5

up vote 35 down vote accepted

Explanation (Brief)

Blender uses a central point to orbit about, in practice this is good for modeling an object which you rotate about a lot to see from all sides (think of a potter using a wheel). But it can be awkward when exploring a scene or modeling something from the inside, for example.

There are however some ways to use Blender without this being an annoyance. ... read on.

Explanation (Detailed)

Blenders view is constructed by 3 elements.

  • location: the point of interest that orbit when rotating the view-port (the center of the screen).
  • distance: the zoom level (distance from the location).
  • rotation: value for yaw-pitch-roll (around the location).

linked to API reference.

Typically users don't need to worry about this detail, however zooming will only change the distance which is an offset from location (where 0.0 is zoomed in as far as possible == no offset).

Solutions

Early on using Blender I was quite annoyed by this limitation, of course there are ways to set a new view-center, common way is to select an object and press numpad ., but what if there are no objects where you want to look at? .. or the object is very large? (a terrain mesh for eg). Sometimes I found myself rotating the view 90d, panning, then rotating back - which seemed an unnecessary workaround.

Here are some ways to navigate in large scenes or scenes with no obvious center...

  • CtrlShift+middle-mouse or Shift++/-: View Dolly,
    works similar to zoom but translates the view center (like panning forward).
    I think this is the most direct answer to your question, but listing other methods too.

  • ShiftF: Walk/Fly Mode,
    As with dolly this can move the view back and fourth (using the mouse wheel), but you can also look around using the mouse and WASD keys, its a mode all on its own and has pros and cons which are better explained elsewhere. See documentation.

  • Interface Preferences: Auto Depth, useful in combination with Zoom To Mouse Position, Using these will make sure the distance is always the value under the mouse cursor, this means you have to consider where you click when moving the view but can also be very handy since it gives you a lot more control.
    If you work with large scenes - like a game level for example, and want to move around a lot, Id recommend to try these options. See this video for a demo.

  • ShiftB: Border Zoom: Also sets the center-point when zooming.

  • AltHome: Centers the view around the cursor.

  • NDOF (N-Degrees of Freedom), also known as a 3D mouse, hardware you can use to navigate a scene with Blender, See devices made by 3dconnexion. Blender's 3D View supports this, allowing you to explore a scene. Walk/Fly modes also support NDOF devices. (Note, this is not a promotion of 3dconnexion, in fact there are very few companies who make such hardware, So currently Blender only supports 3dconnexion)

share|improve this answer
    
Whoa. View dolly which is different from view zoom blew my mind. I recommend Auto Depth to everyone. It's the first thing I turn on. Should be a default, really. –  Wray Bowling Jun 24 '13 at 19:07
3  
@Wray Bowling, the reason its not default is many users like not to have to be aware of their mouse placement when using view operations. By default you can click anywhere for view rotate for eg, but with auto-depth you have to take care to place your mouse somewhere that isnt going to change your depth too close/far. –  ideasman42 Jul 1 '13 at 22:34
1  
Might be useful to mention Alt+Home to center the view at the 3D cursor. If you enable 'Cursor Depth' in the User Preferences to place the cursor on the surface of objects, I find this is the quickest way to specifically place the center of view –  Greg Zaal Sep 1 '13 at 18:18
    
If just the new Walk mode was available as default viewport navigation method... MMB down, move mouse to rotate in FPS style, MMB up to end rotation. + / - and scrollwheel to move forward / backwards. –  CoDEmanX Jan 12 at 17:17

In Blender, when you zoom in or out or rotate the viewport, it always does so around a center point. You can find this point by rotating your display using the third mouse button and finding the spot that always remains in the center. Your problem arises, because Blender essentially reaches the minimum focal distance to that center point, and does not allow you to zoom any further.

You can't override this feature of Blender, but you can instead shift this center point to a more useful location. You can do this in a number of different ways:

  • The simplest way is just by panning the screen (Shift + third mouse button)

  • To reset this center to the origin, press Shift+C, then Alt+Home

  • To set this center to an object in your scene, select that object, then press the decimal point on the numpad (numpad .)

By doing any one of these, you are essentially 'shifting' the viewport camera that you look through, instead of just zooming it in or out.

share|improve this answer
4  
I would like to add to this. If I'm not mistaken, the reason the zoom stops is because the perspective camera that you're essentially looking reaches the maximum focal length. By resettling the view on an object, such as with "numpad ." you are actually moving the camera closer, whereas before it was strictly zooming in and out. –  Jonathan Williamson Jun 5 '13 at 15:03
    
Many of these options don't work on a Mac. There is no third mouse button on my mouse (it has a clickable scrollwheel, but that does not behave as a third mouse button, since it is mapped elsewhere by the system). There is no home button. There is no numpad - I have mapped the numpad and the digits from 1-0 work, but the period (.) doesn't work on a Mac, even after mapping numpad. –  Anand Jun 5 '13 at 15:20
    
@Anand You can emulate a three-button mouse on a Mac. Check out blender.stackexchange.com/questions/124/… –  Gwenn Jun 5 '13 at 15:31
    
@Jonathan Williamson, this isn't related to the focal length of the camera, its simply that there is zero distance to the view offset (internal limitation, explained in my answer). –  ideasman42 Jun 5 '13 at 16:36
    
@ideasman42 ah thanks for that. I was never away of View Dolly, that's insanely helpful! –  Jonathan Williamson Jun 5 '13 at 16:50

There's a limit on how far you can zoom in. If you want to continue zooming in, you'll have to reset your view (as mentioned in a previous answer) or do one of the following:

  • Press ShiftB(when not in a camera) and select an an area. Blender will zoom into that point.

  • Press numpad . this will zoom to the current object.

  • Adjust some of the view camera settings in the Properties area (N)

One major fix for this problem is modeling on a larger scale. Modeling small objects will require more zooming. Keeping objects to scale(proportional to the real world) will generally make modeling easier.

share|improve this answer
    
How do I select an 'area'? Do you mean a mesh or such? I have my cube selected, but clicking Shift B does nothing. Pressing (.) when not seeing current object does nothing. Will try playing with the Properties area... –  Anand Jun 5 '13 at 15:24
    
Shift B will bring up a selector similar to Box Select. Dragging the box will zoom to match the part of the screen you selected. As for (.), you need to select an object then press (.), this will zoom the view camera too the object. –  CharlesL Jun 5 '13 at 15:30

Typically when you can't zoom in as far as you'd like, it's because you're in perspective view instead of orthographic view. You can toggle between the two by hitting the "5" key on the numeric keypad. You can tell what view you're in by looking in the upper left corner of the viewport. It'll tell you the view you're in (such as "front ortho" or "front perspective").

share|improve this answer

For using a laptop, if the Numpad . doesn't do anything, turn off auto perspective mode in user preferences and turn off perspective mode with Numpad 5:

enter image description here enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.