Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

I know how to control fire/smoke particles but flames and smoke always appear to be drifting upwards (i.e. positive global Z-axis) regardless.

I'm actually trying to create a sun-like fireball, i.e. I want the flames to emit outwards in all directions from a sphere. My particles are already doing this but the flames emitted from those particles are still drifting upwards only.

Is this possible at all with the latest release of Blender (2.69 at the time of this writing)?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

Smoke and flames will drift upwards because there is a temperature difference between the smoke/flames and the surrounding air by default, and heat rises.

You can sort of disable this by setting the temperatures to be equal.

Domain settings

Set the Temperature Difference to 0 in the smoke domain settings:

enter image description here

This is all that is needed to make the smoke/fire stop drifting upwards, however more is needed to make it emit in all directions. I think you already have this part, but I wasn't sure so here it is anyway.

Since you are simulating a star, you may not want the smoke that is emitted with the flames by default (even when the flow object is set to only Fire)

You can disable this by setting Smoke to 0 in Domain Settings > Smoke Flames > Reaction:

enter image description here

Particle settings

You probably already know about the particle settings, but:

You can emit particles in all directions by using a sphere and increasing the Normal value which sets the starting velocity in the normal direction. This setting is in Particles > Velocity > Emitter Geometry:

enter image description here

Also ensure you disable Gravity for the particle system (As already mentioned by Mike Pan)
This can be done in Particles > Field Weights > Gravity:

enter image description here

Smoke Flow Settings

Select your particle system as the Flow source, and enable Initial Velocity so that the fire is "flung" by the particles (In other words, the fire will be emitted with the velocity already gained by the particle).

Depending on the speed of your particles, you may also want to increase the number of Subframes.

enter image description here

Result

enter image description here

share|improve this answer
add comment

Particles and smokes are all influenced by gravity, which is set to the earthly value of -9.8m/s/s by default.

You can either turn off gravity completely from the Scene Panel, or turn off the influence of Gravity for a particular particle effect. Please see screenshots below. (Relevant value highlighted in Yellow)

enter image description here

enter image description here

share|improve this answer
1  
I already had the particle system Gravity at 0. It does affect the motion of the particles, but as I wrote, the smoke emitted from those particles still drifts upwards. However, setting the scene gravity to 0 does indeed stop the upwards motion of the flames themselves and I could also use it to have the flames drift in any other (specific) direction. It's not (yet) quite what I was looking for for my fireball, though... I'd need some way to define a given point as the "center of gravity". Currently experimenting with a force field in the middle of the sphere but getting weird results... –  Oliver Giesen Jan 3 at 1:37
    
Ah I see. The other answer by Gandalf3 seems to cover the rest. –  Mike Pan Jan 3 at 1:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.