Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

I have just recently sculpted a Mesh Helmet model and I am needing it to export it for another program. When I switch the mesh into edit mode it turns into its original starting cube. Going into sculpt mode again returns it to my helmet. I didn't think it was an issue, but when I exported it into a .dae file it came out as the cube instead of the helmet. How do I make the helmet show up correctly in Edit mode and the .dae file instead of the cube?

share|improve this question
    
Try applying any modifiers (Alt+C> Convert To Mesh) –  gandalf3 Dec 31 '13 at 3:45
1  
@gandalf3 Wouldn't recommend converting the entire thing to a mesh, OP might have other modifiers. –  iKlsR Dec 31 '13 at 4:02
add comment

3 Answers 3

You more than likely have a Multiresoultion modifier on your object. You can switch to the Modifiers tab and press Apply on the modifier to apply this and see how your object looks in edit mode but if you apply it now, you will lose the ability to adjust any settings on the modifier and you might be left with a really high poly object which is undesirable if you decide to tweak the sculpt later (reduce view levels etc to reduce the load on the viewport).

If you still decide to apply the modifier, I would recommend making a copy of the sculpt just in case.

To keep the modifier and export the sculpt, when using the Collada exporter, look in the properties to the left and tick Apply modifiers.

enter image description here

share|improve this answer
add comment

It sounds like you might have some modifiers on the object.

Try applying them to the mesh data. You can do this either by selecting the object in Object mode and pressing AltC> Mesh:

enter image description here

Or by pressing Apply on each modifier in Properties > Modifiers:

enter image description here

share|improve this answer
add comment

What has already been posted is accurate however I think that maybe some elaboration on how modifiers behave in Edit mode will benefit the OP.

Some modifiers like Sub-surf, Shrink-wrap, and Triangulate have the option to enable previews in Edit mode but the multi-res modifier does not have this option yet. At least so far as I know.

This means that you cannot preview the multi-res sculpted model in edit mode the way you would like to. I would also like to be able to do this. We have to wait for a gifted programmer to show up and finish what Nicholas B. started.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.