Since anything before and after the dot is arbitrary, why bother?
RuntimeError: Error: Registering operator class: 'abcdefg', invalid bl_idname 'abcdefg', must contain 1 '.' character
This rule may seem arbitrary, but looks like there's already some structure in existing operator's names. All registered operators will end up within
When we need an operator to quit Blender, it's available, grouped with other window management operators.
At first I, too, didn't bother with naming, putting everything under
I don't know if it has any other significance, but self-documentation alone made the naming rule worthwhile to enforce.
Developer note: in C code blenders operators are formatted
Then we can expose all operators as
This is arbitrary and we could have chosen not to do it, but I think having each tool in a named category is a good thing.