Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I have a problem where I can see through a box in blender game, see picture. This effect changes so that the near side of the "chassis" of the truck is invisible when I rotate the model

enter image description here

What can I do to not make this happen?

share|improve this question

marked as duplicate by X-27, poor, Samoth, PGmath, someonewithpc Jan 6 at 20:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 9 down vote accepted

The normal (1) of the invisible face points in the wrong direction you can fix that by selecting the face and Ctrl-N.

Screenshot

You can verfiy this by displaying the normals (2)

Alternatively you could disable Backface Culling in the material's Game Settings (3).

share|improve this answer
    
You can also select all of the faces and "flip normals" (W then F). Or select the object and "Recalculate Outside" (Ctrl N). – Thomas Dec 13 '13 at 18:04

I think something wrong with face normals, you could check it this way:

Normals

Usually these lines should be at outer side of object volume. Track body shouldn't be considered as just box without top, it is very thin object with surfaces directed to "inside" and "outside".

share|improve this answer

Try setting its Material's Alpha Blend to Alpha Clip, that usually helps.

*PROPERTIES, MATERIALS TAB, GAME SETTINGS, ALPHA BLEND

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.