Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When you subdivide a cube into 9 smaller cubes,
how to separate them so that between each smaller cubes is a gap ?

But, the mesh is whole so that each smaller cube is not represented by individual smaller cube meshes.

share|improve this question
2  
Could you explain how you intend to subdivide a cube into smaller cubes? Here's a related question Subdivide and separate face into different meshes – Carlo Mar 13 at 12:57
    
In edit mode or using sub. modifier. – vejn Mar 13 at 21:33

If you want individual smaller cubes it would be easier to generate them with an array rather than subdividing a large cube. This is because when you subdivide, Blender doesn't generate internal faces.

  1. Create a cube.
  2. Add an array modifier with a count of 3 and an X relative offset of 1.1.
  3. Add a second array modifier with a count of 3 and a Y relative offset of 1.1.
  4. Add a third array modifier with a count of 3 and a Z relative offset of 1.1.

At this point you should have something that looks like a subdivided cube.

enter image description here

To convert to a single mesh object, select the object then press Alt+C to bring up the Convert To menu then select Mesh from Curve/Meta/Surf/Text.

enter image description here

share|improve this answer
    
Hi, thank you, but I need the other way around. I already made a mesh which needs to be separated in the way I described. – vejn Mar 13 at 13:26

If you want small cubes not to be as individual meshes but still to have a gap between them then I think you want to inset faces of original cube and extrude insetted parts.

  1. Start with subdivided cube (3 times).
  2. Select all, press I to activate Inset tool and then press I once more to inset individual faces.
  3. To make extruded parts (which have gaps between them) not rounded but rectangular their base should be beveled. In order to do that select all small edges in between large ones by selecting several of them and then using Shift+G > Direction.
  4. Press Ctrl+B and then C to bevel selection with Clamp overlap option turned on.
  5. Select any large face (Ngon), press Shift+G > Area to select all these large faces by their areas. Set Pivot Point to Individual Origins for further actions. Extrude selection with E 3 times (or less, but it may lower quality of finished result).
  6. Bevel Ngon once more with Clamp Overlap to make it more rounded. It would be a bit hard to get rid of this Ngons, however as long as they are inside of flat surface they shouldn't be a problem.
  7. Add Subsurf modifier and inspect the result.

gif

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.