Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

enter image description here

As shown in the picture, I have this scene where I want to film this girl from her reflection in the mirror, and from the front I have lighted her face up for the shot, but when I render it with camera pointing to her mirror reflection, her face just appeared pale and unlighted. No matter how much I jack up the light strength (even to a ridiculously high value), it just stay this way.

I tried messing with light paths, limited and full global doesn't make any difference. higher or lower sample rate doesn't make difference. Tried several glossy mode, no difference either.

Anyone know why glossy behave like this? And, if I wanted this shot done properly, what can I do?

share|improve this question
    
Is Clamp Indirect set to something other than 0 in Render Settings > Sampling? – gandalf3 Feb 20 at 21:00
    
yyyyyeeeesssss........GAWD I feel so stupid right now. Thanks for the help gandalf. Actually can I delete this question, god this is so embarrassing... – SVAFnemesis Feb 20 at 21:04
    
heh, I've been bitten by this too XD You can delete if you really want to, but it'd be nice if it could stick around to potentially help others searching google with the same problem – gandalf3 Feb 20 at 21:10
up vote 8 down vote accepted

Make sure Render Settings > Clamp Indirect is set to a suitably high number, or 0 to disable clamping all together.

enter image description here

share|improve this answer
1  
This is a very common issue, and the documentation is unclear on how to use clamping. Users start with a very low value, and those low values bring down the brightness way down. for more info read: blender.stackexchange.com/a/45381/1853 and blender.stackexchange.com/questions/39157/… and: blender.stackexchange.com/a/17749/1853 – cegaton Feb 20 at 22:07
2  
@cegaton I've updated the manual regarding this, hopefully it's clearer now. – gandalf3 Feb 22 at 6:17

i had the same problem ,the problem is your glossy shader is set to a impossible number (0.000). you should try placing your glossy shader at (0.003). at 0.000 the calculations for the shader become error-ed.

share|improve this answer
3  
Your answer is being flagged as low-quality. Consider elaborating on e.g. what setting on the glossy shader shouldn't be set to 0 and why, and maybe even adding some example images to back up your explanation. Thanks :) – gandalf3 Feb 22 at 5:51

You could just bake the texture with the lighting on her face the way you want, that way you can focus on the reflection shot brightness, however if you are animating her face, this can get ugly, but if you are just showing her reflection this might be the way to go.

IF her face is not animated:

I would put in a mix node to mix between the "normal" material nodes and the baked texture, that way you can always move the slider when it is convenient to do one over the other.

IF her face is animated:

I would take a video shot of her front on, and then use that video on the mirror surface as a material/texture.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.