Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

In my 3d scene view, with display mode set to "textured", my texture looks fine. But when I render it the texture stretches all over the place. All my settings are at default, just a single sun object for lighting.

Scene view Rendered

share|improve this question
1  
Make sure the mapping is set to UV in the texture settings –  gandalf3 Aug 8 at 22:39
    
That was it, thank you! –  user5530 Aug 8 at 22:44
1  
@user5530 If gandalf3's advice helped you, please accepted his answer, be click on the check mark. –  GiantCowFilms Aug 8 at 23:11

1 Answer 1

Ensure that you have UV mapping selected in Properties > Textures > Mapping > Coordinates:

enter image description here

If you only have one UV map it's not necessary to select it in the Map drop down, but you can if you want.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.