Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

I'm currently trying to spread pebbles along a plane using particle systems. Moreover, I wanted it so that it only spread on certain areas of the plane (which can be done using weight painting & adding a vertex group).

The problem is, whenever I tried to weight paint the plane, nothing shows up in my 3D viewport. No red/colors that usually appears during weight painting.

Please take a look at this 'blend file', and see what's wrong with my weight painting. I'm pretty confident that it should've worked like normal.

enter image description here

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You have 'Face selection masking' turned on in the 3D view header:

enter image description here

This means that only faces that are selected in edit mode will be able to be painted on when weight painting. It's useful to use as a mask in case you want certain parts of the mesh to be excluded from weight painting.

Either disable this button or select all the faces that you want to weight paint in edit mode before returning to weight paint mode.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.