Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

I created a interior scene and i don't know how to bake a texture using cycles bake.

share|improve this question
    
You don't have to be in Object Mode to bake, it will bake in Edit Mode as well (at least it works on my computer). But really make sure that you have selected the texture node and chosen the right image for it. Another reason could be that your object has more than one material assigned to it. In this case they all have to have image textures assigned to them - you could choose one image for all materials of your object if the uv maps don't overlap or different images for different materials. –  tk1214 Sep 2 at 12:49

2 Answers 2

up vote 5 down vote accepted

With out more detail about the situation, it's hard to say how you might go about this if there are any special considerations.

Here are the basics:

  1. UV unwrap your object.

  2. Create a new image in the UV/image editor (AltN or Image > New).

  3. Add a texture node to the objects material(s) and select the new image:

    enter image description here

  4. With the texture node selected, press bake in Properties > Render settings > Bake:

    enter image description here

The color and shading on that object will be rendered to the image specified in the selected texture node.

If you switch to textured shading once this process is complete (for each object), the viewport will look something like this:

enter image description here

See the wiki for more detail about the various options.

If you want to bake multiple objects to the same image:

  1. UV Unwrap your objects in such a way so that the UV maps don't overlap. An easy way to do this is by pressing Space> Smart UV unwrap or Space> Lightmap pack with all the objects selected.

  2. Bake each object with Clear disabled so that the existing pixels in the target image aren't erased before the baked shading is overlayed.

    enter image description here

Example .blend.

share|improve this answer
    
I followed you steps but bakeType Combined is not available in my properties settings not able to generate image. –  Sachin Vani Jun 26 at 14:15
    
Are you sure that you have the render engine set to Cycles. The selection menu is at the top center of the main window. Also, make sure that you have a recent build. Cycles bake has only been included for about a month now. –  MarcClintDion Jun 26 at 17:58
    
Thanks , I was using blender 2.7 , i downloaded 2.71 and options are available. Now after pressing bake i get message No active layer found in the object –  Sachin Vani Jun 27 at 5:56
    
@user1755630 Sounds like it can't find the image to bake to.. Make sure you have an image texture node in all the materials used by the object you are baking. Also make sure they are selected, and are pointing to an image. –  gandalf3 Jun 27 at 6:00
    
I do this process with one cube object and render engine is set to the Cycles and also have an image texture node but still i get message "No active UV layer found in the object " –  Sachin Vani Jun 27 at 6:19

You have to be in object mode to bake. So unwrap in edit mode, create your new image in uv image editor by splitting a window, name it and save it on your hd. Now, go into object mode, select the image texture node so that it is highlighted in orange, then hit bake. Then, re save the image under the image drop down. I had the same problem.

Then, I got a new problem that required me add an image texture to another object in the scene before bake the current one.

share|improve this answer

protected by gandalf3 Sep 2 at 18:08

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.