Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

I can't find the option to add a new object then new texture and image. I am trying to create a 3D map from a heightmap image.
I have watched a few tutorials but the one that shows how to add a new object is for a different version with a different layout.

share|improve this question

2 Answers 2

To add a new object, you can

  • Press ShiftA in the 3D view and then select the object you want to add.

    enter image description here

  • Press Add at the bottom of the 3D view and then select the object you want to add.

    Add menu

share|improve this answer

Firstly, press Shift + A, or change the tab on the Toolbar to "Create" and then select the Plane primitive.

When creating a mesh with a heightmap you will want to first subdivide it a couple of times by pressing W and then selecting the Subdivide option. When you have pressed the Subdivide button you can either press F6 to bring up the options menu or make sure you have the toolbar activated (the one on the left) by pressing T, both will provide you with the same resources. After you've pressed F6 or if you are looking at the bottom of the Toolbar you will see options for the subdivision menu. Crank up the number of cuts to something like 30-50, depending on the detail you want.

Once that's done, go to the Modifiers panel (the wrench icon to the left hand side of the UI) and add a subsurf modifier (or press CTRL + 1/2/3depending on the level of subdivisions you want) to get even more detail.

After you have added the subsurf modifier, add a Displace modifier. Press the New texture button and then click on the checkered board button in the same row as the wrench one. Once there, change the type to Image or Movie. After that you want to press the Open button and select your heightmap, and you should be set. If it is effecting your mesh too much, you can turn down the Strength parameter in the displace modifier.

Oh, and if it isn't working, try to UV Unwrap your plane first. You do this by making sure you are in edit mode Tab and then selecting everything with A, and then press the U button. Also make sure that the Subsurf modifier is at the top of the stack.

I hope I didn't "overanswer" your question, and I also hope I formatted it okay. I'm new to the site! :)

share|improve this answer
1  
Welcome :) If you need any help formatting, there is a comprehensive guide here. –  gandalf3 Jun 26 at 1:24
    
@gandalf3 Excellent, thanks a lot! –  Raksom Jun 26 at 1:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.