Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

I am watching this tutorial on youtube:

enter image description here

At the moment, the tutor is merging the hand's vertexes to the arm's vertexes; the problem is that when I try to merge them like that, they don't really get really well merged and end up having empty space between them. This is what I am saying:

enter image description here.

How can I fix this? Thank you already!

share|improve this question
    
Try doing it without mesh display enabled on the subserf modifier (triangle icon). I'm not sure why it's working in the video, though it does look like he was using 2.62 (I'll test it in 2.62 in a second..) –  gandalf3 Jun 17 at 22:18
    
@gandalf3 Dude!! Thank you so much! You don't know how happy I am; I have been searching for a solution for hours already. Awesome! No need to test it if you want to. –  Vinicius Jun 17 at 22:24
1  
This does work in 2.62. I'll report this (and another bug I found while testing this). In the meantime, a faster way to merge two loops (assuming the vertex counts are the same): 1. select the loops you want to merge 2. Bridge them (W > Bridge) 3. Enter edge select mode (Ctrl Tab > Edge) and Ctrl Alt Right click on one of the newly created edges 4. Press Alt M > Collapse. If the vertices are lined up enough, you could also try W > Remove doubles with the two loops selected, then press F6 and increase the merge distance. –  gandalf3 Jun 17 at 22:25
    
Thanks! It worked perfectly. –  Vinicius Jun 17 at 22:27
add comment

1 Answer 1

up vote 3 down vote accepted

The video is of 2.62, where this seems to work. In current versions of blender you need to disable Applied edit cage on your modifiers for snapping + auto-merge to work reliably:

enter image description here

I've reported this here.


However, in this case there are some potentially faster ways to merge these loops.

Loops with equal vertex count, but not necessarily even vertex placement:

  1. Select both loops and press W> Bridge Edge loops (E)

  2. Switch to edge select mode (CtrlTab> Edge) and select the newly created edge ring by pressing CtrlAltRMB over one of the new edges.

  3. Press AltM> Collapse to collapse the selected edges.

enter image description here

Loops with lined up vertices, but not necessarily the same vertex count:

  1. Press W> Remove doubles and up the merge distance in the redo panel (F6). This will result in triangles with uneven vertex counts, and it could produce tris even with equal vertex counts.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.