Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

I'm trying to display models that have shading drawn or baked directly on the textures, but I can't figure out how to disable Blender's default scene lighting. If there are no lights in the scene, everything is black, but I want to see the textured objects fully bright. How do I disable the lighting?

NOTE: Just before posting this, I found the "Shadeless" material property, which does more or less what I want. However, is there a way to globally toggle the default lighting?

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

Yes, you can enable Shadeless in 3D view > Properties (N) > Shading while in textured view:

enter image description here

If you are in BI, this only works if using Multitexture shading:

enter image description here

If you are using GLSL in BI or material shading in Cycles, you'll have to use shadeless in the material settings for BI and a emission shader for cycles.

share|improve this answer
    
Thanks for this answer. The reason I didn't spot the Shadeless option there is that Multitexture has always failed to render textures on any PC I have tried it on, and I always have to end up using GLSL. Maybe I should ask about that in my next question! –  MrFlamey Jun 4 at 15:58
    
@MrFlamey I doubt it's a hardware issue (usually GLSL shading is the one with problems..), but you never know. Here's a related post: blender.stackexchange.com/q/5283/599. –  gandalf3 Jun 4 at 18:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.