Take the 2-minute tour ×
Blender Stack Exchange is a question and answer site for people who use Blender to create 3D graphics, animations, or games. It's 100% free, no registration required.

I'm new to rigging, and am trying to make a low-poly rabbit. I've made the armature and spent the better part of an hour fine-tuning the weight painting only to find out that posing nearly any bone in the armature deforms the head. I've gone over the head again and again in weight painting mode to be absolutely sure that none of the head's vertices could possibly be under the influence of any bone but the head bone, but it's no use. I can't really pose the rabbit at all--just making the rabbit tilt its ears back deforms the head so badly, it's unrecognizable. I tried normalizing and then inverting all of the weight paint to see if that would bring up the offending vertices, but that only messed up the paint job when I reverted it back the way it was. The ears affect each other a bit, too--it's more noticeable the further away they're placed from one another.

Attached is my file, sans normalization of weight paint (I don't think it was really necessary, and aside from the head-warping, all the bones control exactly what I want them to.) Many of the bones don't have any corresponding vertex group because they're only there to anchor other bones in place. Could that be the reason?

My wonky-headed rabbit: http://pasteall.org/blend/29225

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

Blue doesn't necessarily mean zero. When a vertex is only affected by one bone, a tiny amount of weight is enough to deform it like it had a weight of 1.0. And even if a vertex has a main deforming bone near by (even with a weight 1.0) it can be noticeable when a bone with low influence is too far away and moves differently.

You can easily see the offending groups by going into Edit Mode, choosing a group of interest (Vertex Group list in the Vertex Group panel) and clicking on the Select button of the Vertex Groups panel. This will select all vertices in this group, no matter what weight they have. You can also remove the stray vertices from the group by selecting them only and clicking on the Remove button of the panel.

enter image description here

You can also see the groups of a vertex in the N-Panel and remove them there (click the X button of the group you want to remove). When you choose Deform, only the deforming groups are visible.

enter image description here

In Weight Paint mode you can also use the Use Zero Weights option (T-Panel,Options) to show problems in your weighting. Select Active and all vertices with zero weight of the selected bone are shown in black. As you can see, selecting the leg shows weights in blue around the head. Which means the leg bone is deforming the vertices of the head.

enter image description here

You can also see problems with no weights at any bone using All. As you can see there are some black areas near the leg. This would mean these vertices will not move at all. Note that this also includes non-deforming groups, so seeing no black vertices can be misleading.

enter image description here

To clean vertex group weights (in Weight Paint mode) use the Clean tool (T-Panel,Weight Tools). Click the Clean button and the tool options will be shown as in the image below. You can select a threshold in the Limit field. All vertices below this weight will be removed from the group automatically:

enter image description here

Another thing useful while weight-painting is to use Wireframe Display mode (with Limit selection to visible turned on) frequently. That way the shading doesn't obscure the weight colors. It also helps to locate the vertices better so you don't have to guess where to aim with your cursor.

enter image description here

Usually these problems stem from using a blend mode like Mix while painting. If you want to remove weights completely, it is often better to use Subtract with full Strength and Weight.

enter image description here

share|improve this answer
    
I also noticed that your group layering is a bit messed up which looks suspicious to me (bug). So you might need to remove the same groups twice in edit mode. Wonky-Head Rabbit_cleanup.blend –  user2859 May 17 at 15:09
    
Thank you so much! I had no idea you could look at vertex weights any other way. I went through and cleaned up all of the vertex groups. The rabbit still had the same problem, though. Then I noticed your comment here, and the fixed version you posted. What did you do differently to get the rabbit to pose this way? I am not sure what you mean by group layering. I'm also not sure how you got the spherical axes (is that a preference?) –  badcree May 17 at 15:56
    
@badcree I had to delete some groups twice (means press remove two times), which could be a bug in blender. Maybe all that inverting and normalizing has something to do with it? I need to investigate that further. The posing is just rotating the bones with rotate manipulator (the little blue arc icon in the viewport header right next to the menu for view modes etc). –  user2859 May 17 at 16:09
1  
Further to the second image - there is a contrib addon called show vertex weights that can show that list for all selected vertices not just the one active vertex. –  sambler May 18 at 5:08
1  
@user2859 It doesn't need to be added - just thought it could be noted below for those interested in looking further. –  sambler May 18 at 8:51
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.